Widget issue

After editing a widget I have to close the page and re-open it to edit another widget on the same page. Bug?

Jerome, does any type of error message appear, or does the new widget simply not open up when you select the edit button? What types of widgets are you opening up? Lastly (but maybe most importantly), have you cleared your browser cache recently? Odd behavior in the UI can often be solved by simply clearing your browser cache.


Do you have any Javascript running on that page? You can try to either comment out the script temporarily or use the “Disable Javascript” function in the editor to see if it is being caused by that.

After some digging and trial and error testing, it looks like it is a conflict with the Site Catalyst code. If i remove that, the widgets become editable. Are there other CM1 users that the support group is aware of using Site Catalyst and are having success with it not conflicting with the system? Right now there is the widget issue and page load times that are terribly slow (between 30 seconds and two minutes to activate the page) when I click the Edit button. When I remove the Site Catalyst code, everything works fine so there is some kind of conflict happening. If other CM1 users are using Site catalyst, I’d love to know how their performance is doing.


Are you using FireFox or Chrome? FireBug in FireFox and the built-in Console in Chrome will reveal the Javascript error that is creating this issue. If you go to the page, before even adding a widget, right click in the page and select Inspect Element. In Chrome, I believe the Console is on the right sight of the Inspect tool tabs and in FireBug it’s on the left. You can even click the error to see where it’s coming from.

It might shed some light on the issue and what the exact script issue is.

Thanks Daved, I tried both FireBug and Chrome Console and they didn’t show any errors. More digging in order I guess.