Percussion with 90+ users running slow

I’ve noticed that after getting all of my users online and all my content on Percussion now, that it has started to run slow. Is there anything I can do to speed it up?

Hi Matt,

Yes, there are a few steps we can take towards improving CM1’s performance. I see you have already filed a support ticket for this issue; I’m going to follow-up with you through that support case in order to gather some more details pertaining to your current configuration.

From looking over Matt’s server log file, I spotted this error message, which was appearing during the periods of time when the application’s performance appeared to be compromised the most:

java.lang.OutOfMemoryError: GC overhead limit exceeded

This indicates that the CM1 JVM has run out of memory. As outlined in this help document, we made adjustments to CM1’s max JVM memory allocation:

http://help.percussion.com/publishing…

In Matt’s case, because his machine has 8GBs of available RAM, we bumped the max JVM memory allocation from 1.2GB, all the way up to 3GB. To do this, in his PercussionServer.lax file located at CM1’s root directory, we found this line:

# -----------------------------   
# Java arguments   
 
lax.nl.java.option.additional=-Dprogram.name=RhythmyxServer.exe -Xms256m -Xmx1228m -Djava.endorsed.dirs="AppServer/lib/endorsed" -Djava.library.path=./bin -server -XX:MaxPermSize=256m -Dfile.encoding=UTF8 -Dsun.jnu.encoding=UTF8 ```   
 
And changed that to:   
 
``` # LAX.NL.JAVA.OPTION.ADDITIONAL   
# -----------------------------   
# Java arguments   
 
lax.nl.java.option.additional=-Dprogram.name=RhythmyxServer.exe -Xms256m -Xmx3072m -Djava.endorsed.dirs="AppServer/lib/endorsed" -Djava.library.path=./bin -server -XX:MaxPermSize=256m -Dfile.encoding=UTF8 -Dsun.jnu.encoding=UTF8 ```

Hey Nathan,

I’ve started experiencing slow down again. I have change the memory allocated to 6GB and let it run that way for about 3 to 4 weeks now but still having days where Percussion takes what seems like 20 minutes to open/save a page.

Hi Matt,

Obviously it shouldn’t take this long to open or save a page. I’m going to open a support ticket so that I you can share you log file with me. Please check your inbox in just a moment.

Nathaniel,

I rebooted the server this morning so it’s running great right now. I can copy the log file though the next time it starts to run slowly.

Sounds good, Matt. Keep us posted.

Hi,

Now that I have all my cm users in things seem slow. I was working last night and now this morrning there seems to be a big difference. It takes 40 secs to open my index page in cm1 ususally it was under 10 sec. I sent my hosting company this post and they check out the settings and said this;

I just logged into the site from several different computers here and all of them display the page very quickly, so I don’t see any issues with the web server, plenty of available resources also. I also looked at the Percussion server and while I don’t see resources maxed out, I do see approximately 20-25% of cpu being used for java. In total however the percussion server has only half its memory in use and only 30% of cpu being used.
Is it possibly due to some internet issues at your end?

Other other websites load fast, Youtube.com loads in 2 secs, and videos I’ve never watched before load and play smoothly within 2 or 3 secs.

What else can I check? Its painful to try and make any changes right now.

Ok so my server guys made some more adjustments and it seems back to normal. Thanks Robert!

Me again. Ok another day before a deadline all my users are in and I’ve gotten about 5 emails now saying that its running really slowly which I notice as well. Chrome Kill this page error message pops up. I don’t think any changes have been made since we went through this the last time.

Any ideas on how to troubleshoot this?