New CM1 5.3 SR1 Patch Available - Patch ID - 5315_20180125

A new Patch (Patch ID - 5315_20180125) is available for CM1 5.3 SR1.  This cumulative patch includes all prior patches  for this version, as well as the new updates added in this patch.  More information can be found on the help site and on the Support Portal

We recommend that all CM1 customers plan to install this patch.  Let us know if you have any questions!

-n 

Thanks Nate. 

I have couple of questions

  • if we hold out till 5.4, will the 5.4 have these 5.3 SR1 patch? 
  • re: [CMS-3476] - Missing broken link icon after installing patch - if I mouseover these icons, will it have tooltip telling you what they are? Example: mouseover error icon will tell you that the link to PDF is archived or broken.

Hi Aaron,

Releases are cumulative so everything in the 5.3 Patches will be in the 5.4 release.  I wouldn’t recommend waiting as the Patch does include several Accessibility improvements and a Security update and there is still work to be done before 5.4 ships. 

The shortcut to the item on the Warning links didn’t make the cut for the patch, but the intent is to continue to improve on the link management capabilities in future updates.   Inline images warning/errors were also skipped for this patch but we’d like there to be an indicator on those similar to the way links are handled.

-n

I have a found a BIG problem with the patch. Insert Link function in the Rich Text Editor does not work. Typing /Assets/documents/… path did not work. I had to type the entire http: path.
Insert image doe snot work either.
I’m going to create a support ticket.

Following… that’s what I use all the time. 

I just found out that it seriously messed up my home page. Banners are stacked behind other content instead of rotating. Now I have to immediately throw editors out and un-install the patch.
NOT happy.

Hi Lloyd,

It may have been that after the patch install that the browser cache needed cleared in the CM1 UI.  I see that you are working with support, we will get someone on the phone to help you sort out your issue. 

-n

Just to clarify.  If you install the Patch and Full publish, and then uninstall the Patch.  You will need to run a Full Publish after the patch uninstallation.  Otherwise the JavaScript and markup on the published site will be mismatched with the version of CM1. 

I don’t see that noted in the Patch Install / Uninstall instructions so we will add a step for that. 

-n

The banner issue does appear to be a problem with the patch.  Empty HTML attributes are being incorrectly removed from html in the Rich Text Editor.  We are updating the patch to correct this and will repost links one that is done. 

In Lloyd’s case the data-orbit="" for the Foundation slider is being incorrectly removed. 

Will post an updated patch once this issue is corrected. 
-n

I can confirm that clearing the browser cache in the CM1 UI resolved this issue. 

Hi All,

We have a new patch available on the support portal that addresses a few known issues.  Please let us know if you have any questions.

Regards,
CW

Hi Chris,

I will be attempting tomorrow morning. I’ll let you know how it goes.

Thank you,

Morning Chris. Patch is installed with no apparent issues. Problems from the other day seem to have been resolved.Thank you for your help.
L.

Thanks Lloyd :slight_smile:

-Samrudhdi