HTML5 video tag issue

I’m grateful that CM1 allowed you to use HTML5 via Rich Text Editor (RTE). Although it’d be awesome if HTML widget support HTML5 too

For some reason, CM1 stripped these values from the code: autoplay and loop inside ```

 tag, and tried different method such as  
``` and ``` ``` (same for loop), neither worked. Help!

Here's an example of what I did and how's it working:

Source: and


EDIT: For some reason, the topic subject line wouldn't allow me to put ``` ``` in there, that's why it was removed.

Hey Aaron,

Try using the PRESERVE tags in the HTML widget.

<preserve> <br> <!-- Code goes here --> <br> </preserve>   

This should prevent the HTML widget from tempering with your HTML 5 mark-up.

It worked! Thank you!

In preview mode, the video started to play only after 30 seconds? Could it be a bug or something? The non-percussion version worked blazing fast. Please let me know.


We tested the video internally and it worked just fine (even without the PRESERVE tags).

What version of CM1 are you on?

I’m on Version 3.3.4 Build 201310R30 (0)

I tried it here and it seems to load just fine. I also was able to add your code with out the preserver tags and the HTML widget did not strip out anything.

When I removed the tag, it doesn’t play at all on Safari. It started to play on Chrome, like 30 seconds later. It played right away on Firefox.

What do you think it might be? I do not see any errors.


Are you using this code ?

<video loop autoplay> <br>
<source src="" type="video/mp4"> <br>
<source src="" type="video/ogg"> <br>
Your browser does not support the video tag. <br> </source></source></video>   

I have tested this and it worked with or without the preserve tags on IE8, Chrome and Firefox. The issue maybe caused by something else on your pages (or Template). Try creating a blank page with just the video html on it. This might help with the load time as-well.

Also, you are a CM1 version behind. Cm1 version 4.0.5 has been released and 4.1.0 is scheduled to be released at the end of next week. Upgrading may help with this issue.

*4.1.0 will be released at the end of this week,

@armani - yes! that’s a good solution! Sorry for the very late reply!