full site publish not posting template changes.

Full site publish does not post changes made to the template on all pages.

Hello Scott,

Can you tell us more about the changes that are not publishing?  Are they images, widgets, css updates?

The first checks would be to 

  • check for publishing errors
  • if they are assets, make sure they are approved
  • do a hard refresh on the published pages to make sure you are not seeing a cached page

If these tips do not help please let us know a little more about what you are seeing.

Regards,
Keith

Keith, 
I do not see any publishing errors. 
The template assets were in quick edit status, I approved them and they are now in pending status. I will run another full site publish tonight as it is taking 7 hours to complete. 
The pages that we publish by themselves are showing the template changes but I thought a full site publish would reflect those changes as well and it did not.

  • made changes to template.
  • published index page and it reflected the change
  • performed full site publish and changes to any other pages did not show.
  • opened Assets in template(header/footer) and they do show the changes but were in quick edit status
  • approved header/footer assets

will republish tonight to see if those changes are pushed. 
I thought that changes to the template would propagate down through the indexing. I also thought that a full site publish would push the template changes down through the pages. If I understand you correctly, you need to approve changes to the assets within the template and after a full site publish the changes will be visible correct?

Hello Scott,

If all assets used by a template are approved and pending, a full publish should update all pages using those templates and assets. 

If your next full publish does not update everything let us know.  We can meet to look at your setup in more detail.

Keith

Thanks Keith.

Hi Scott, 

Just to add to Keith’s questions, I wanted to check to see if you are using the ‘Ignore Unmodified Assets’ feature in your publishing configuration? 

Peter

I do not believe so, where would I check to see that?

Hi Scott,

To see whether or not you are using the feature Peter mentioned above, you would need to click on the Publishing tab, double click your site, and then click on the server name in which you are publishing from.  Next, click the wrench above the site’s configuration to bring up a configuration dialog.  You can select if you are using ‘Ignore Unmodified Assets’ here.  It might be worth removing this selection this to see if this resolves the issue.  Were your pages published with the correct content after you approved the widgets on those pages?  Let us know, if they were not we might want to bring this into a support ticket.

Regards,
Chris W

      

I do not see an ‘Ignore Unmodified Assets’ option in our full publish configuration window.
Is this something that was implemented after version 4.4.4?

Hi Scott, 

Yes, it was added in version 5.1 so if you are running 4.4, there is no chance that it is affecting your publishing. I’ll convert this into a support ticket and follow up in the thread once we have a solution for the benefit of others.

Peter