Deleting Content Types

I was trying to clean up my obsolete content type that we have in our Rhythmyx server. I logged on to the workbench, and tried to delete the Content Type from Content Design view. It gave me the following error:

Could not delete the design object of type ‘Content Type’ with id ‘318’ as it is referenced by objects of the following types: Content Item/Folder

I went to Content Explorer and removed from all folders all the content items of the type to be removed. I went back to Workbench, and on delete, still observe the same error.

Also is there any way to view all the content items from the workbench?


There may be content items that don’t have parent folders… Try looking under the “All Community Content” View. That’ll include such content items.

You have to “Purge” these content items, not just “remove” them (which only removes them from the folder, it doesn’t delete them).

This may require moving them to a different workflow state.

Thank you very much Dave…I was able to purge them and then delete the content types from the workbench.

The other question I had was for curiosity that is there any way to view content items from the workbench?