Deleted widget and can't get my content back

I accidentally added text to a blog post area on one of my templates. It then added all the content I posted in the template to my posts. I removed the content when I noticed this but non of my blog posts are populating with any content at all now.

What can I do to solve this?

Hi Evan,

When you say you removed the content from the template, did you open the widget and remove the content manually or did you actually click on the x icon on the widget in the content tab? If you did the former, that will not completely clear the widget of “content”. Clicking the x icon on the widget within the “Content” tab should clear the widget completely, which should allow the page level content to resurface.

Let me know if this helps.

-Jon

What happens if I’ve deleted the whole widget out entirely. Is there a way to restore what I’m sure I totally goofed up?

Evans ,

Try checking you Unused Assets Trey. The content of the widget may be there.

We see it on the page level but we want to be able to do it on the template level. This problem happened when I had accidentally added content in edit layout mode and not edit content mode.

Evan,

Try adding the widget back to the template and the content should fall back into place.

If that doesn’t work you can add the widget to the template, Then use the unused assets trey to add the content back to the widget (page level), Then promote the content to the template level.

To promote page level content to the template you,

  1. open the page (the page with the content) for editing,

  2. click on Actions > edit Template,

  3. Click on the content tab

  4. click on the widget with the content

  5. click on the first icon (up arrow) to promote content to template.

Please let me know if this works

Hello,

I have just run in to a similar issue, where I have deleted on the template level an HTML widget. Now all of the pages that use this template are missing the content. I tried following your steps, Armani, but all of the pages end up with the content I have “promoted.” Any thoughts as to how I can get the original content to populate the block?

Thank you,

Brian

My apologies for the double post… I we can not get the widget block back, is there any way to restore to a previous version of the template?

After you add the Widget back to the template do not promote the content up to the template level. If you have already promoted the content up just click on the “x” (delete) button on the widget WHILE ON CONTENT TAB. This will delete the content from the widget.

This will leave a widget on the template empty of content. Now each pages content should return. If it does not check the unused asset tray for the content. If you see it there simply click and drag the widget content in the unused asset tray over the widget where the content was originally and that should populate the widget with that content.

Let me know if you can not find your original content.

I have tried adding the html widget back in to its original position, which was the region with the ID “temp-region-17” but it is not letting me place the HTML widget there. Will this cause a problem?

Are you adding the widget from the page or Template level?

Yes.

You can only add a widget on a page to an empty template region. so if you are trying to add the widget via the Page Editor you may need to switch into Template Edit and add the HTML Widget from there.

I apologize, I was not clear. Yes, I am trying to add it via the template editor.

If there is a widget on a page in a region you can not place a widget via the template in that same region. Are there any other widgets in that a region? if yes, are the widgets on the template or Page?

Hi Armani,

In tying to solve this, I have since made the matter worse, and now no content is appearing at the page level. Is there any way to restore to a previous version of the template?

unfortunately there is no way to return to a previous version of a template. Brian let’s take a look at this together off line. I will be emailing you shortly.

Thank you.